FME Flow:2025.1

Échec de l'authentification SAML

Symptôme

Lors de la connexion àFME Flow avec les informations d'identification d'un fournisseur d'identité SAML, l'authentification échoue avec un message similaire au suivant :

Ce problème peut survenir surDistribué installations deFME Flow qui utilisent un serveur d'applications Web Apache Tomcat et se connectent à un fournisseur d'identité SAML via unproxy inverse.

Cause

La demande HTTP de connexion SAML n'a pas envoyé l'URL du proxy inverse au fournisseur d'identité SAML.

Résolution

  1. Ajoutez l'URL de votre proxy inverse aufmeserver.saml.custom.baseurl= ligne dans le fichier application.properties SSO. Si votreFME Flow utilise un serveur d'application Web Apache Tomcat fourni avec l'installation, ce fichier se trouve dans <FMEFlowDir>\Utilitaires\tomcat\webapps\fmesaml\WEB-INF\classes\.
  2. Par exemple:

    fmeserver.saml.custom.baseurl=https://monserveur

  3. RedémarrageFME Flow.